View Single Post
  #5  
Old 08-16-2009, 10:32 AM
chanstevens's Avatar
chanstevens chanstevens is offline
Rocket buildin' machine
 
Join Date: Jan 2007
Location: Cincinnati OH
Posts: 520
Default

The flight pranged, electronics failed, cost me 1600 meet points (was first in static, would probably have held on with the cluster points). No idea what went wrong--flight was fantastic, MUCH faster/higher than the boilerplate, but I'd gone 3xC6 instead of B6, pushing razor thin stability margins. Timer needs 2g for half second to convince itself it's flying versus being carried to the pad, and I think I'd certainly cleared that. Continuity and start-up chirps were fine on the rod. Post-flight doesn't look like it fired on the inside of the tube, but the sleeve on the xmas bulb was gone, and it was heat shrink on there pretty good. Might have dislodged the powder (held in tube by crumpled wadding rammed in tightly, loose wiring (doubtful--it was hard pulling it out post-flight), maybe a timer loosely mounted jiggling around. In any case, that one flight wound up bumping me from 1st to 2nd for the meet, from 2nd to 3rd for the year, wiped out what would obviously have been a top placement event trophy/medal, and destroyed what was a darned fine model .

Very frustrating . I eventually plan on building another one, since all the hard work's already done (scaling, spec'ing parts, working out the stability, etc.). Well, everything except figuring out how to deploy anything...
Reply With Quote